CloudFlare и проблемы с ним

Тема в разделе "Скачивание картинок и файлов", создана пользователем BlackCard, 4 июн 2018.

  1. BlackCard

    BlackCard Member Пользователи

    Регистрация:
    8 мар 2018
    Сообщения:
    30
    Здравствуйте. Раньше сайт, с которого парсилась информация, был на обычном хостинге.
    Но потом его перенесли на CloudFlare (с защитой от DDoS атак) и повылазила куча проблем.

    1) Из-за ожидания 5-6 секунд перед загрузкой страницы сайта очень сильно увеличилось время парсинга, на каждую страницу стоит WAIT:7000, но иногда даже этого мало, поэтому вынужден был поднять аж до 10000.

    2) Перестали качаться картинки. Раньше реализовано было это в "поиск-замена" следующим образом:

    Код:
    re:src=\"(.*?)\"|src="!@#%$1============$1%^&*"
    re:src=\'(.*?)\'|src='!@#%$1============$1%^&*'
    %^&*|</DOWNLOADFILE>
    ============|[/BEFORE_IMG_REPLACE][/DFN]<DOWNLOADFILE>
    !@#%|[DFN][TRANSLITE][REWRITE]{path}G:\01. ПАПКА{/path}[BEFORE_IMG_REPLACE({sep}{break}/{skip}{sep}/)]
    
    Все прекрасно качалось.
    Но после переноса и подключения WbApp - парсер даже их не качает, тупо пустые src.
    Хотя если в поиск-замене посмотреть, все должно работать.
    Кстати, если картинки не качать, а оставлять - мой сайт их тоже не видит до первого обновления страницы.

    3) WbApp меняет местами некоторые участки кода. Это создает проблему, ибо некоторые проекты и границы делались очень тонко, приходится теперь все 9 проектов перестраивать.

    Больше всего интересуют пункты 2 и 3, как можно решить проблему?
    Не знаю где создавать тему, поэтому создал из-за 2 пункта тут. Простите, если не там.

    [Добавлено модератором]
    Продолжение темы:
    Баг-репорты
     
    Последнее редактирование модератором: 6 июн 2018

Поделиться этой страницей