POST, CIS, предпросмотр есть, [DOCSOURCE] данных нет.

Тема в разделе "Решение проблем с использованием программы", создана пользователем Kreol, 13 фев 2020.

  1. Kreol

    Kreol Модератор Команда форума Модератор

    Регистрация:
    6 янв 2013
    Сообщения:
    2.589
    После введения новой библиотеки CIS и галочки принудительной конвертации данных для post запроса все чаще не получается получить нужные данные.
    Во вложенном примере, если включить % кодирование для post данные возвращаются, но они все одинаковые, а должны быть разные.
    Если отключить % кодирование то данные правильные в предпросмотре, а в [DOCSOURCE] данных нет.
    Возможно что-то не так делаю?
    ссылка
    Скрытое содержимое:
    **Скрытое содержимое: доступно при наличии 1 постов.**
     

    Вложения:

    • error.cdp
      Размер файла:
      38,8 КБ
      Просмотров:
      1
  2. Root

    Root Администратор Администратор

    Регистрация:
    10 мар 2010
    Сообщения:
    12.223
    Напишите адрес WEB страницы, где можно посмотреть нужный запрос.
     
  3. Root

    Root Администратор Администратор

    Регистрация:
    10 мар 2010
    Сообщения:
    12.223
    Этот сайт принимает русские POST данные в UTF8 кодировке.

    Для отправки запроса в UTF8 нужно в заголовки запроса добавить строку:
    Код:
    Charset: utf-8
    2020-02-13_13-22-17.png

    2020-02-13_13-22-40.png
     

    Вложения:

    • error.cdp
      Размер файла:
      40,1 КБ
      Просмотров:
      0
    Kreol нравится это.
  4. Kreol

    Kreol Модератор Команда форума Модератор

    Регистрация:
    6 янв 2013
    Сообщения:
    2.589
    Я понял ошибку, я вставлял вот такую строку
    content-type: application/x-www-form-urlencoded; charset=UTF-8
    upload_2020-2-13_12-41-28.png
    но он ее не обрабатывает правильно из-за =
    Возможно это можно учесть и доработать. Но буду иметь ввиду.
     
    kagorec нравится это.

Поделиться этой страницей