POST запрос в GETMORECONTENT

Тема в разделе "Решение различных задач по парсингу", создана пользователем emkub, 5 сен 2018.

  1. emkub

    emkub Member Пользователи

    Регистрация:
    16 мар 2015
    Сообщения:
    88
    Здравствуйте, друзья.
    Просто беда с POST запросами в GETMORECONTENT.
    Уже в который раз сталкиваюсь, и всё время какие-то трудности.
    Получается сделать наобум, даже точно не знаю, как оно выходит.
    Вот, очередной раз... Бьюсь, и всё бес толку.
    Вот Ссылки недоступны для гостей, зарегистрируйтесь или авторизуйтесь на форуме! Есть выбор производителя. При выборе подтягивается цена.
    На скрине всё хорошо видно: и заголовок, и передаваемые данные (выделил красным).
    Но куда вставлять их в программе??? Перепробовал разные варианты - всё не то.
    Помогите пожалуйста разобраться, какие данные в какие поля вставлять?
    Прикрепил проект.
    ВООБЩЕ не пойму, раз срабатывает, 20 раз не срабатывает.
    Что я делаю не так?????
     

    Вложения:

    Последнее редактирование: 5 сен 2018
  2. Kreol

    Kreol Модератор Команда форума Модератор

    Регистрация:
    6 янв 2013
    Сообщения:
    2.257
    <GETMORECONTENT><URL="[SELF][POST]productId=576&pageUrl=%2Faudi-a3-06-04-06-07audi-a3-nakladki-na-ruchki-dvernyie-4-sht-stalflypage-tpl.html&class=catalog-item__[/POST]"><HEADERS>x-requested-with: XMLHttpRequest</HEADERS><START=""><STARTCOUNT="0"><END=""><ENDCOUNT="0"><PARAMS=""></GETMORECONTENT>
     
  3. emkub

    emkub Member Пользователи

    Регистрация:
    16 мар 2015
    Сообщения:
    88
    Конкретно такой вид загружает целую страницу.
    Пробовал добавить <HEADERS>x-requested-with: XMLHttpRequest</HEADERS> в свой проект - не помогло.
    <URL="[SELF] - ставил "Ссылки недоступны для гостей, зарегистрируйтесь или авторизуйтесь на форуме! " с передачей параметров [PARAM] - не помогло.
    Ставил и "%2F" и "/" - без результата...
     
  4. Kreol

    Kreol Модератор Команда форума Модератор

    Регистрация:
    6 янв 2013
    Сообщения:
    2.257
    перепробовав кучу вариантов пришел к выводу, что
    1) сайт довольно часто не обрабатывает запрос
    2) что-то с гетмором, ибо при настройке границ Гетмора выдачу видно, но при парсинге/ предпросмотре 0
     
  5. inotoxic

    inotoxic Well-Known Member Пользователи

    Регистрация:
    13 сен 2015
    Сообщения:
    272
    Тестировал в ZennoPoster - то же самое
     
  6. Kreol

    Kreol Модератор Команда форума Модератор

    Регистрация:
    6 янв 2013
    Сообщения:
    2.257
    3 раз встречаю такой. Научились делать глючное г.
     

Поделиться этой страницей