При запуске Webapp разлогинивается IE

Тема в разделе "WBAppIE", создана пользователем d19codec, 13 июл 2019.

  1. d19codec

    d19codec New Member Пользователи

    Регистрация:
    6 ноя 2015
    Сообщения:
    18
    При запуске Webapp разлогинивается в IE, и в Webapp, соответственно, я оказываюсь не авторизован.

    Стояла windows 7 и все прекрасно работало целый год. Просто запустил IE (версия 11.00.9600.18666), авторизовался на сайте нужном, закрыл IE и забыл о нём. Потом захожу в webapp (ctrl+W два раза), там открывается страница, и я авторизован, всё хорошо. Хоть сколько запускай webapp целый год, пока не зайдешь в IE и сам не разлогинишься на сайте - всё работает, авторизация не сбрасывается.
    Поставил windows 10 ltsc (в ней нет edge, тоже IE, стоит версия 11.557.17763).
    Логинюсь в IE, захожу в Webapp (ctrl+W два раза) - открывается страница без авторизации, проверяю в IE - действительно не авторизован, хотя даже браузер не закрывал и авторизовался минуту назад. А если не запускать webapp - даже после перезапуска IE авторизация не слетает.

    Проект тот же самый, ничего не менялось. Авторизацию лучше оставить по тому же принципу, т.е. не настраивать авторизацию при каждом парсинге, т.к. она еще и с reCAPTCHA.
    Как один раз авторизоваться и забыть как и раньше?
    Кстати, можно совет сразу для WBAppCEF, мне понравилось как он быстро страницы открывает. Можно и под оба решения.
    Да, я понимаю что проблема может в IE, но спрашивать больше негде по CD.
    CD обновляю постоянно как есть обновы.
    Спасибо.
     
    Последнее редактирование: 13 июл 2019
  2. Root

    Root Администратор Администратор

    Регистрация:
    10 мар 2010
    Сообщения:
    11.455
    Здравствуйте.

    Назовите адрес сайта и под хайдом данные для входа на него.
     
  3. d19codec

    d19codec New Member Пользователи

    Регистрация:
    6 ноя 2015
    Сообщения:
    18
    Это сайт биржи, лишних логин/пасс нет к сожалению для теста. Но чтобы увидеть хоть как выглядит вот адрес
    Скрытое содержимое:
    **Скрытое содержимое: доступно при наличии 20000 постов.**
    Но неделю назад работало всё под семеркой. Косяк явно у меня в софте, то ли с этой версией IE не так работает, то ли сам IE косячный, но настройки стандартные в обоих случаях были и IE оба 11 версии, только последние цифры отличаются. Я просто хочу понять куда копать хоть примерно.
     
    Последнее редактирование: 13 июл 2019
  4. Root

    Root Администратор Администратор

    Регистрация:
    10 мар 2010
    Сообщения:
    11.455
    Без логина и пароля я не смогу потестировать работу механизма залогинивания на сайте.
     
  5. d19codec

    d19codec New Member Пользователи

    Регистрация:
    6 ноя 2015
    Сообщения:
    18
    Даже при попытке задать обычные границы парсинга - страница открывается уже без авторизации. Проверил даже CD с февральской версией.
    А при проверке на вируталке вин7 - демо версия не сбрасывает, но и не подхватывает авторизацию.
    Логин/пасс от сайта бессмысленен, т.к. там при входе с другого ip куча подтверждений нужно сделать даже на минимальной защите на новом акке, проще сразу регистрироваться с нужного ip.
    Буду дальше думать методом тыка что не так с софтом, хотя даже понятия не имею что попробовать.

    upd проверил Авито, авторизация не сбрасывается. Буду думать.
     
    Последнее редактирование: 13 июл 2019
  6. Root

    Root Администратор Администратор

    Регистрация:
    10 мар 2010
    Сообщения:
    11.455

Поделиться этой страницей