Не подгружается контент

Тема в разделе "Решение различных задач по парсингу", создана пользователем Dandrei, 15 июл 2018.

  1. Dandrei

    Dandrei New Member Пользователи

    Регистрация:
    4 ноя 2017
    Сообщения:
    23
    Доброго времени!
    При парсинге с sudrf.ru на загружается весь текст страницы.
    Например: Ссылки недоступны для гостей, зарегистрируйтесь или авторизуйтесь на форуме! дела&from=p&r={ в коде отсутствует "Текст документа". Причем, браузер видит такой текст, а код его не содержит.
    Пробовал через WBApp открывать текст документа в новой странице - не помогло, код все также без текста.
    Пробовал подгружать ссылку через макрос <GETMORECONTENT> но та же история - код не содержит контента.
    Подскажите, где прячется контент ))))
     

    Вложения:

    • sud_rf.cdp
      Размер файла:
      41,5 КБ
      Просмотров:
      1
  2. Dandrei

    Dandrei New Member Пользователи

    Регистрация:
    4 ноя 2017
    Сообщения:
    23
     
  3. Dandrei

    Dandrei New Member Пользователи

    Регистрация:
    4 ноя 2017
    Сообщения:
    23
    Ребят, может кто сталкивался с этой проблемой? Очень актуально.
     
  4. inotoxic

    inotoxic Well-Known Member Пользователи

    Регистрация:
    13 сен 2015
    Сообщения:
    293
    Может так?
     

    Вложения:

    Dandrei нравится это.
  5. Dandrei

    Dandrei New Member Пользователи

    Регистрация:
    4 ноя 2017
    Сообщения:
    23
    В данном проекте все также - текст решения не подгружается...
     
  6. Dandrei

    Dandrei New Member Пользователи

    Регистрация:
    4 ноя 2017
    Сообщения:
    23
    Перебрал все скрипты через <GETMORECONTENT> и все равно текста в коде нет, а он при этом в браузере отображается.
    Видимо данные где-то выводятся отдельно, а вот где понять не могу.
    Буду признателен за помощь!
     
  7. Dandrei

    Dandrei New Member Пользователи

    Регистрация:
    4 ноя 2017
    Сообщения:
    23
    Разобрался с загрузкой в режиме WBApp: в режиме настройки WBApp код виден, нужный текст подгружается:
    [WAIT]:8000
    [CLICK][classname][N]0[/N][FULL]:bigField
    [WAIT]:10000
    [GETHTML]

    но если начинаю запускать парсинг, то код подгруженной страницы не считывается, WBApp не возвращает ничего, что должно перейти в GETHTML.
    На темах форума нашел сообщение от админа о том, что некоторые сайты с WBApp не грузятся.
    Может это и есть такой сайт? Кто подскажет, что сделал не так?
     

    Вложения:

    • sud_rf_2.cdp
      Размер файла:
      199,8 КБ
      Просмотров:
      1
    • 111.wbapp
      Размер файла:
      685 байт
      Просмотров:
      1

Поделиться этой страницей